Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Pages: [1] 2

Author Topic: Flyable Xwing  (Read 13199 times)

adriaan

  • Member
  • **
  • Posts: 91
  • newbie
Flyable Xwing
« on: June 11, 2013, 08:33:28 am »

hi, i converted an xwing and used the mig29 script to make it fly. now it keeps making errors and isnt' fast enough. could someone help me?



https://mega.co.nz/#!KIAzyLjR!B-djqy0xa1No-6iFlPmKjRnMINlK8YyKJWWJSqK1gLQ
« Last Edit: June 11, 2013, 08:44:49 am by adriaan »
Logged

bugsblake

  • Sr. Member
  • ****
  • Posts: 255
  • jedi master
Re: Flyable Xwing
« Reply #1 on: June 11, 2013, 09:36:53 am »

well the errors are because your script is telling it to play sounds that are not in the aircraft folder!

as for not being fast enough! your xwing.xml points to an engine file in the jbssim/engine folder! so im guessing its just using the migs default engine!

what you want to do is copy that engine file and rename it to xwing_engine or something! then change the engine in the xwind xml to point to that engine! now if that all works without having screwed anything up, you can now open your new xwing_engine file and tweek the power! ;)

hope that helps!
Logged
Intel 6 core i7 Xeon - 4930k @3.40 GHz
GTX 770 4GB X2 in SLI
Asus P9X79 Extreme MOBO
Patriot 16GB DDR3 1600MHz
SSD 250GB + SATA 500GB + SATA 1TB

adriaan

  • Member
  • **
  • Posts: 91
  • newbie
Re: Flyable Xwing
« Reply #2 on: June 11, 2013, 10:30:41 am »

thanks! yeah i fixed the sound. added bump maps. and did the engine thing you said.
it goes faster now but my left and right aileron don't respond anymore.
could someone have a look at it?
download: https://mega.co.nz/#!fIBBRTaS!Wz9qqxGvVBh2M3R-3PaIqBxP_29itqM4VGOPQOOD-jg

and these are the jsbsim files https://mega.co.nz/#!nNZXlSpA!R0iCNGphbTTNXI9lpibhqlvvtvYqKmGth3eNtMle0TQ




« Last Edit: June 11, 2013, 05:45:19 pm by adriaan »
Logged

WormSlayer

  • Member
  • **
  • Posts: 71
  • Half-Life VR
Re: Flyable Xwing
« Reply #3 on: June 11, 2013, 04:35:01 pm »

Sweet, I was going to make an X-wing for my collection of spacecraft but now I just have to wait for you to get this one working right :D Do the wings deploy?
Logged

adriaan

  • Member
  • **
  • Posts: 91
  • newbie
Re: Flyable Xwing
« Reply #4 on: June 11, 2013, 05:40:48 pm »

nope i don't have a clue how do that. do you have any idea?
Logged

WormSlayer

  • Member
  • **
  • Posts: 71
  • Half-Life VR
Re: Flyable Xwing
« Reply #5 on: June 11, 2013, 06:05:00 pm »

No clue whatsoever, I still havent even managed to get a simple car working XD
Logged

Atrax

  • Full Member
  • ***
  • Posts: 119
  • newbie
    • AtraxGaming Game Shop
Re: Flyable Xwing
« Reply #6 on: June 14, 2013, 06:15:35 am »

That is an awesome model! :D Hope someone that knows what he's doing will check it and fix it for you. Great model!
Keep up the great work!

adriaan

  • Member
  • **
  • Posts: 91
  • newbie
Re: Flyable Xwing
« Reply #7 on: June 14, 2013, 08:04:09 am »

the handling is fixed. it flies fine
Logged

bugsblake

  • Sr. Member
  • ****
  • Posts: 255
  • jedi master
Re: Flyable Xwing
« Reply #8 on: June 14, 2013, 09:44:33 am »

nice xwing! glad you got it sorted! im "still" stuck trying to get my landing gear working on my UAV! i got the front wheel to close (off axis) in a test but having to re do the whole xml as i started with a copy of another plane! but for some reason the diles i made dont want to work! will get it finished one day, then it will be uploaded for all! ;)
Logged
Intel 6 core i7 Xeon - 4930k @3.40 GHz
GTX 770 4GB X2 in SLI
Asus P9X79 Extreme MOBO
Patriot 16GB DDR3 1600MHz
SSD 250GB + SATA 500GB + SATA 1TB

WormSlayer

  • Member
  • **
  • Posts: 71
  • Half-Life VR
Re: Flyable Xwing
« Reply #9 on: June 15, 2013, 06:35:46 pm »

When I spawn this one in game, I dont see any model?
Logged

adriaan

  • Member
  • **
  • Posts: 91
  • newbie
Re: Flyable Xwing
« Reply #10 on: June 15, 2013, 06:55:51 pm »

me neither. after the update it was gone. will reupload if i fix it
Logged

WormSlayer

  • Member
  • **
  • Posts: 71
  • Half-Life VR
Re: Flyable Xwing
« Reply #11 on: June 15, 2013, 06:59:31 pm »

Hah guess I missed it for now, at least it wasnt just me being dense XD
Logged

NOACeulemans

  • Jr. Member
  • *
  • Posts: 16
  • Dreamer
Re: Flyable Xwing
« Reply #12 on: June 15, 2013, 07:39:45 pm »

Phew, I thought I'd installed it wrong :P
Logged

bugsblake

  • Sr. Member
  • ****
  • Posts: 255
  • jedi master
Re: Flyable Xwing
« Reply #13 on: June 15, 2013, 08:19:30 pm »

found the bug! since the update the matlib files of craft have had the mats renamed!

if it was "chrome_102" and you renamed it to "chrome" the the matlib file, outerra seems to have renamed it to "chrome_102" again! so it cant find the textures!

you should just be able to reinstall the craft again and it should work again! otherwise you will have to rename them in the matlib itself! ;)



EDIT: never mind, not a bug! i had re imported the other day and forgot! thought it had happened to your file too but was wrong! not sure whats up with your file? try to re export it and re import it into outerra and see if its still giving you trouble? or if that fixes it?
« Last Edit: June 15, 2013, 08:53:10 pm by bugsblake »
Logged
Intel 6 core i7 Xeon - 4930k @3.40 GHz
GTX 770 4GB X2 in SLI
Asus P9X79 Extreme MOBO
Patriot 16GB DDR3 1600MHz
SSD 250GB + SATA 500GB + SATA 1TB

adriaan

  • Member
  • **
  • Posts: 91
  • newbie
Re: Flyable Xwing
« Reply #14 on: June 16, 2013, 04:57:07 am »

i'll make a new one. it was pretty bad anyways
Logged
Pages: [1] 2