Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Pages: [1] 2 3

Author Topic: Hello. I have issues.  (Read 16485 times)

mori

  • Member
  • **
  • Posts: 63
  • newbie
Hello. I have issues.
« on: July 18, 2013, 11:21:28 am »

How to delete imported files from the list of imported files.
I don't like not being able to manipulate that.
Next where to find an example DAE file with predefined lods
and stuff, i have no idea what's written on wiki page,
it's like some ancient mesopotamian without pictures.
>>>>>>>>>>>>>>>>>>>>EXAMPLE FILE<<<<<<<<<<<<<<<<<<<
please.

And why this site is so slow? Is it a feature?
And i need to verify myself every time i post? Joking?
What is this?
Logged

PytonPago

  • Hero Member
  • *****
  • Posts: 2282
  • It´s way too complex, dont let me try to explain !
Re: Hello. I have issues.
« Reply #1 on: July 18, 2013, 12:07:57 pm »

How to delete imported files from the list of imported files.
I don't like not being able to manipulate that.
Next where to find an example DAE file with predefined lods
and stuff, i have no idea what's written on wiki page,
it's like some ancient mesopotamian without pictures.
>>>>>>>>>>>>>>>>>>>>EXAMPLE FILE<<<<<<<<<<<<<<<<<<<
please.

And why this site is so slow? Is it a feature?
And i need to verify myself every time i post? Joking?
What is this?

well, a lot is changing in time ... user-made small import helps are on forum scattered doe. There was the simple tatra model posted http://www.outerra.com/forum/index.php?topic=284.msg3275#msg3275   ... i try to make something when my project is working like it should ... (there are some troubles now, so a little wait is needed) ... doe, people will help if you ask specific questions. They are nice, friendly people.  ;)

... verifying always after posting ? ... like wanting you to login every time ?
Logged
We are still undeveloped as long as we don´t realize, that all our science is still descriptive, and than beyond that description lies a whole new world we just haven´t even started to fully understand.

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #2 on: July 18, 2013, 02:32:13 pm »

Yeah sorry for attitude.
So there's only a 3ds model not dae.
I need some example of how to compose hierarchy in dae file.
Logged

PytonPago

  • Hero Member
  • *****
  • Posts: 2282
  • It´s way too complex, dont let me try to explain !
Re: Hello. I have issues.
« Reply #3 on: July 19, 2013, 03:40:58 am »

Yeah sorry for attitude.
So there's only a 3ds model not dae.
I need some example of how to compose hierarchy in dae file.

... no ofence taken  :D ... well, the hierarchy is taken as a base of bones for the importer (should keep that in mind), there are a few good posts already :

http://www.outerra.com/forum/index.php?topic=1558.0

http://www.outerra.com/forum/index.php?topic=1591.msg18043#new
(the hierarchy image is missing i think, but simply, all wheels are parented to the base, witch is primary in hierarchy - but would see in importer videos too, as ite hierarchies match in the script-enabled bones menu of the importer)
http://www.outerra.com/forum/index.php?topic=1558.msg17857#msg17857
http://www.outerra.com/forum/index.php?topic=1721.msg21821#msg21821

... would be good, if you go trough all of those topics ... may even ask their creators a thing or two if interested more too ... 
I will try give my model when it works correctly ...

... as for the verifying problem, it should not do that all the time. Maybe there is some option in your browser, not allowing the cache be written (not indexing that you logged in already) or some cache-cleaner getting that done ... try look into that.
« Last Edit: July 19, 2013, 03:42:33 am by PytonPago »
Logged
We are still undeveloped as long as we don´t realize, that all our science is still descriptive, and than beyond that description lies a whole new world we just haven´t even started to fully understand.

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #4 on: July 22, 2013, 07:04:39 am »

Me with my issues again.

Just raw baked ao.
Im trying to import it using Nvidia Tools for photoshop
for conversion.

First - no ATI1 format.
No idea where is it.
After importing into engine i see this

And it is DXT1 and you can see the texture is there, it's just
wrong.
What i am doing wrong?

Logged

angrypig

  • Sr. Member
  • ****
  • Posts: 454
Re: Hello. I have issues.
« Reply #5 on: July 22, 2013, 11:58:29 am »

What do you want to achieve? ATI1 format can be used only for reflectance/roughness/opacity maps. The only tool able to generate ATI1 is command line version of Nvidia Texture Tools (i don't know why it isn't included into Photoshop plugin)
https://developer.nvidia.com/gpu-accelerated-texture-compression

Logged

murkz

  • Full Member
  • ***
  • Posts: 151
    • The Antisocial Gamer
Re: Hello. I have issues.
« Reply #6 on: July 22, 2013, 01:42:34 pm »

I use gimp for the dds conversion.

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #7 on: July 22, 2013, 02:13:02 pm »

The problem is that it doesnt read the texture.
I can't figure out where it is stored in the first place, where the engine copyes it when i import.
And also, because it doesn't update the model when reimporting, and i can't delete entries in
imported list i have this mess -

I figured out tow LOD's work, node hierarchy,
now im figuring out the texture importing, and i
have no luck yet making it work.
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Hello. I have issues.
« Reply #8 on: July 22, 2013, 02:57:36 pm »

The old models can be deleted from your data directory (you selected during install, by default c:\users\yourwinname\outerra). The packages are folders under packages/morikubo/. Model files are *.objdef, delete the ones you don't want. A package can contain multiple models and skin files, so the importer doesn't delete other objdef files there when importing. Textures are in that folder too.

On AMD the textures won't load when they extents are not multiples of 4.

You may have to edit the matlib file to assign the texture to the right slot, please post the matlib file.

Logged

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #9 on: July 22, 2013, 04:28:50 pm »

The old models can be deleted from your data directory (you selected during install, by default c:\users\yourwinname\outerra). The packages are folders under packages/morikubo/. Model files are *.objdef, delete the ones you don't want. A package can contain multiple models and skin files, so the importer doesn't delete other objdef files there when importing. Textures are in that folder too.

On AMD the textures won't load when they extents are not multiples of 4.

You may have to edit the matlib file to assign the texture to the right slot, please post the matlib file.

Thanks for mentioning that directory! :)
Texture is 1024, i have nvidia gtx670, matlib i think is allright


Code: [Select]
[
{
"name" : "White__Water_Tower_LOD0_",
"diffuse" : "185,185,185,255",
"Ax" : "7",
"Ay" : "7",
"m" : "127",
"tex_diffuse" : "0_Water_Tower_1_diffuse.dds",
"tex_normal" : "",
"tex_env" : "",
"tex_opacity" : "",
"tex_reflectance" : ""
}]

So.. :/
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Hello. I have issues.
« Reply #10 on: July 22, 2013, 04:35:30 pm »

And the dds texture looks ok in Irfan?
Try renaming the dds file to something shorter, as well as in the matlib file - there was a problem with long file names once.
Logged

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #11 on: July 22, 2013, 05:07:15 pm »

And the dds texture looks ok in Irfan?
Try renaming the dds file to something shorter, as well as in the matlib file - there was a problem with long file names once.

Sad that yes, its ok in irfan, and short name doesnt seem to help
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Hello. I have issues.
« Reply #12 on: July 22, 2013, 05:34:45 pm »

Hmm, then it looks as if the texture coordinates weren't there or something. Are there some warnings/errors in the import log?
Logged

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #13 on: July 22, 2013, 07:42:22 pm »

Hm... how the engine reacts on overlapping uvw?
Cuz i have a lot of it in my models
maybe that's the case.
But udk for example eats that, and only the lightmap uvw must be non-overlapped.
I have one warning on details(which is separate model in that package), but i havent worked with them yet.
Can it be possible that engine uses 0 channel, and 3ds exports 1 channel?
Can i be the case? I tried to change to 0, but max wont let me do that.
Logged

mori

  • Member
  • **
  • Posts: 63
  • newbie
Re: Hello. I have issues.
« Reply #14 on: July 23, 2013, 09:29:38 am »

Well, since there is not solution, i will be doing next model and wait for patch.
Logged
Pages: [1] 2 3