Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  


Outerra Tech Demo download. Help with graphics driver issues

Author Topic: Supersampling and Oculus Rift  (Read 3667 times)


  • Newbie
  • Posts: 1
  • newbie
Supersampling and Oculus Rift
« on: October 12, 2014, 05:54:34 pm »


First of all I would like to thank you, Cameni and your team, for your wonderful work on this engine and its fantastic support for Oculus Rifts - for me the best implementation out there in a sim and so often close to give me this disturbing feeling of presence. However the lack of resolution on the DK2 sometimes breaks the immersion, in particular when flying over trees where the lack of a good AA probably makes things flicker too much.

In UE4 demos, for instance Realistic Rendering, I had a chance to experience a supersampling mode ("sp hmd 200", in a console) and this greatly enhanced the details thanks to a much better AA. Apparently (I did not try it), this also makes text more readable in Elite:Dangerous cockpits. So I was wondering if it was possible to implement a supersampling strategy for rendering to the Rift in Outerra, a way to configure the framebuffer size before wrapping to the DK2 1080p screen?
I tried to "override native resolution" with a "normal" screen res set to 3820x2160 (thanks to nvidia's new DSR option on their GTX 980/970), but it looks like only the upper left quarter of the 4k framebuffer were displayed on the Rift screen (i.e. not rescaled by nvidia driver? - a screenshot of the faulty rendering results in a perfectly wrapped 4k image).

Btw, this DSR option dramatically enhances the image quality on a standard 1080p screen - grass blades and tree flickers - though there is another flicker on trees due to their lighting or something like that.




  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6721
  • No sense of urgency.
    • outerra.com
Re: Supersampling and Oculus Rift
« Reply #1 on: October 13, 2014, 01:14:55 am »

The override option is meant precisely for that, as it's normally used for DK1 to run in 1920x1080. In case of DK1 though, the downscaling was done by the box and not by the GPU. I guess it's not working right because the pipeline is not set up properly for it. I will experiment with it a bit.