Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Author Topic: Audio lag problem when recording video  (Read 172 times)

fly77

  • Sr. Member
  • ****
  • Posts: 433
Audio lag problem when recording video
« on: May 13, 2019, 04:12:36 pm »

I have noticed that when recording videos in outerra if the scenery contains lots of stuff or high polygon models or when a bit of explosion smoke is added then I allways have a lag between audio and video. When I switch camera view then the  sound gets even more out of sync. This lag is not present however while inside the game..it just occurs in the recording. I will try with external video recording software but its a pity that outerra's recorder apparently has this problem.
Tried fraps  adding  -allowext commandline to outerra.exe . Records video and audio without lag but recorded video includes artifacts (square in left bottom) and terrible jitter. Tried various combinations half/full size different fraps fps recording settings sync on /off etc...but could not get it working so far. I'm using outerra 17.1.0.9891 as it works better for me for model testing.
I'm using these video.cfg settings...maybe I can change something to solve the audio-lag problem so to continue using outerra's internal recorder ? Some suggestion of cfg changes ?

Code: [Select]
vpxenc = "vpxenc --codec=vp8 -p 1 -t 4 --rt --cpu-used=0 --end-usage=cbr
--target-bitrate=60000 --undershoot-pct=95 --buf-sz=6000 --buf-initial-sz=4000
--buf-optimal-sz=5000 -v --kf-max-dist=999999 --min-q=4 --max-q=56"


« Last Edit: May 14, 2019, 03:07:17 am by fly77 »
Logged

fly77

  • Sr. Member
  • ****
  • Posts: 433
Re: Audio lag problem when recording video
« Reply #1 on: May 14, 2019, 02:20:25 am »

I changed video.cf to the following

vpxenc = "vpxenc --codec=vp8 -p 1 -t 4 --rt --cpu-used=0 --end-usage=cbr --target-bitrate=20000 --undershoot-pct=95 --buf-sz=6000 --buf-initial-sz=4000 --buf-optimal-sz=5000 -w 1280 -h 720 --fps=30000/1000 -v --kf-max-dist=999999 --min-q=4 --max-q=56"

then running outerra in 1280 x 720 screen things seem to work now..no more audio lag when recording with the outerra recorder   :)

seems problem was "too much data to transmit"
« Last Edit: May 14, 2019, 02:46:02 am by fly77 »
Logged