Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Pages: 1 ... 29 30 [31] 32 33 ... 51

Author Topic: Graphics driver issues, startup problems (32 bit)  (Read 409722 times)

driflysh

  • Newbie
  • Posts: 8
  • newbie
Re: Graphics driver issues, startup problems
« Reply #450 on: March 25, 2014, 03:11:05 pm »

Hello,

after one of the last updates at least the cylindrical view seemed to work so I bought the alpha. Unfortunately this view doesn't work in cockpit view. And spherical still doesn't work in free flight, outside or cockpit view. Some Screens are attached fo cylindrical cockpit, spherical cockpit and spherical free flight. Straight ahead both cockpit views are just black screen. Trees are very small and sometimes "jump" infront of me depending on view direction, only in spherical.

The Issue regarding heaven display seems to be fixed already.

I also just discovered that the sim gets stuck from time to and can be reanimated by right-mouse looking combined with pushing steering buttons...

Log: http://pastebin.com/6ZRQGYLi

Anyway great work up to now!
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #451 on: March 25, 2014, 06:13:25 pm »

Cockpits won't work reliably in this mode until they are dynamically tesselated and clipped, since this mode is technically a hack over the linear rasterizer. But the rendering of trees in spherical mode seems to be another bug.
Logged

driflysh

  • Newbie
  • Posts: 8
  • newbie
Re: Graphics driver issues, startup problems
« Reply #452 on: March 27, 2014, 03:59:41 pm »

Oh, that doesn't sound like there'll be a solution for the cockpit view soon. Can I deactivate the cockpit-model? Cause I can live without instruments but flying a helicopter on three 42" screens with this stretched view will render me sick after 30sec...
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #453 on: March 27, 2014, 04:47:58 pm »

You can set sim_mode = true in eng.cfg
If you have perf issues after that, you can also press alt+e while in the aircraft, and edit set_fps_position to move the camera in front of the plane.
Logged

driflysh

  • Newbie
  • Posts: 8
  • newbie
Re: Graphics driver issues, startup problems
« Reply #454 on: March 28, 2014, 04:17:54 pm »

sim_mode = true works perfectly! Thank you very much!

Unfortunately that heaven-issue (like a ring in one color, differing in size and angle, starting at the horizon) occured again, but not only in cockpit view and very seldom. But it's ok right now cause I'm only looking at the mountains and trees anyway. ;)
Logged

DivineSense

  • Member
  • **
  • Posts: 75
  • What is the Mind?
Re: Graphics driver issues, startup problems
« Reply #455 on: March 30, 2014, 09:13:58 pm »

Serious startup issues here. Dark star sky is shown, high CPU and program goes unresponsive.
Sometimes the login window is shown without textures. Sometimes it actually starts and is completely fine, maybe 1 in 20 tries works.

I've tried reinstalling Outerra from scratch.

Win64-bit Nvidia gtx660.

Attached my eng.log

Edit: Managed to start it with debug-flag set in eng.cfg.
First I'm getting:
ERROR: (DRV): Buffer performance warning: Buffer object 4 (bound to GL_PIXEL_UNPACK_BUFFER_ARB, usage hint is GL_STREAM_DRAW) is being copied/moved from VIDEO memory to DMA CACHED memory.

Then when the terrain loads:
ERROR: (DRV): Pixel-path performance warning: Pixel transfer is synchronized with 3D rendering.


New Eng-log attached.
Newest Nvidia drivers just cleanly installed (335.23)
« Last Edit: March 30, 2014, 10:59:54 pm by DivineSense »
Logged
Cognitive Scientist - VR Enthusiast - Immersion Junkie - UX Professional - Flight Sim Enthusiast - Amateur Musician - Amateur Actor - Semi-old Soul - Caffeine Addict - INFP

obren

  • Newbie
  • Posts: 3
  • newbie
Re: Graphics driver issues, startup problems
« Reply #456 on: April 09, 2014, 05:55:58 am »

Hi, guys. I have a startup error, and I presume it's because the latest beta Nvidia driver 337.50, I'm not sure tho. I get the error message, Its something like: Failed to precompile shader, open GL error, failed to link shader program, etc. Anybody has similar issues?
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #457 on: April 09, 2014, 06:08:34 am »

Serious startup issues here. Dark star sky is shown, high CPU and program goes unresponsive.
Sometimes the login window is shown without textures. Sometimes it actually starts and is completely fine, maybe 1 in 20 tries works.

...

Sorry I haven't caught this.
There's one potential problematic module that seems to be injecting into Outerra:
Code: [Select]
C:\Program Files (x86)\DisplayFusion\Hooks\AppHookWIN6032_E500B5BA-2E1F-46A5-A503-6D04045D70A4.dll (Binary Fortress Software, DisplayFusion Hook), version 5.1.1.11

Can you try stopping it before running outerra.exe?
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #458 on: April 09, 2014, 06:10:08 am »

Hi, guys. I have a startup error, and I presume it's because the latest beta Nvidia driver 337.50, I'm not sure tho. I get the error message, Its something like: Failed to precompile shader, open GL error, failed to link shader program, etc. Anybody has similar issues?
We'll check this, but Nvidia beta drivers often break OpenGL stuff, while the subsequent WHQL drivers again behave correctly ...
Logged

2eyed

  • Sr. Member
  • ****
  • Posts: 350
  • newbie
Re: Graphics driver issues, startup problems
« Reply #459 on: April 09, 2014, 09:31:32 am »

Same for me, fatal error at startup:
exception msg:OpenGL error:failed to link shader program
last
RL:MapRender::post@c\_root\srcsvn\eng3x\src\test_frat\maprender.h
pp(401)
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #460 on: April 10, 2014, 03:37:00 am »

It seems to be a bug in the Nvidia beta drivers, access violation inside the driver on one of the shaders. Doesn't report anything else but "internal exception", so it's nothing we can do with it except suggesting to avoid these drivers.
Logged

DivineSense

  • Member
  • **
  • Posts: 75
  • What is the Mind?
Re: Graphics driver issues, startup problems
« Reply #461 on: April 10, 2014, 01:17:59 pm »

Hi!

Yes, I suspected the DisplayFusion Hook, but it's the same with that service turned off...
And I'm running WHQL drivers 335.23, not beta for me.
« Last Edit: April 10, 2014, 01:20:36 pm by DivineSense »
Logged
Cognitive Scientist - VR Enthusiast - Immersion Junkie - UX Professional - Flight Sim Enthusiast - Amateur Musician - Amateur Actor - Semi-old Soul - Caffeine Addict - INFP

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #462 on: April 10, 2014, 03:58:02 pm »

Did it disappear from the eng.log when you turned it off?
Logged

Levi

  • Hero Member
  • *****
  • Posts: 585
    • Outerra Mods Site!
Re: Graphics driver issues, startup problems
« Reply #463 on: April 11, 2014, 08:19:36 am »

Hi!

Yes, I suspected the DisplayFusion Hook, but it's the same with that service turned off...
And I'm running WHQL drivers 335.23, not beta for me.

Hi! I'm using the same drivers (335.23 WHQL) on my old GeForce GTX 550 TI, and it works perfectly nice for me.

Logged

Foxiol

  • Full Member
  • ***
  • Posts: 101
  • Gamer
Re: Graphics driver issues, startup problems
« Reply #464 on: April 11, 2014, 02:58:09 pm »

The game gave me a "Fatal Error" with drivers 337.50 in Outerra, and there are other issues with other games such as Planetside 2 giving black screens and such. Yesterday it gave me a Blue Screen and my PC rebooted.

I installed the drivers 332.21WHQL and those have no problems at all...no problems with Outerra, no problems with black screens.

I recommend to hold with the 332.21 until Nvidia fixes their drivers. 
Logged
Pages: 1 ... 29 30 [31] 32 33 ... 51