Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Pages: 1 ... 46 47 [48] 49 50 51

Author Topic: Graphics driver issues, startup problems (32 bit)  (Read 409720 times)

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #705 on: January 21, 2017, 07:30:59 am »

This version may have some slowdowns of its own, one bug fix that aimed to fix terrain corruption under high load has effectively decreased parallelization in terrain tile creation.
Logged

josem75

  • Sr. Member
  • ****
  • Posts: 286
  • newbie
Re: Graphics driver issues, startup problems
« Reply #706 on: January 21, 2017, 09:05:09 am »

This version may have some slowdowns of its own, one bug fix that aimed to fix terrain corruption under high load has effectively decreased parallelization in terrain tile creation.

Now this make a bit sense for me. I had computer problems. I instaled all motherboard drivers, the newest bios. use turbomode. Superpi problem was related with Mh, 1500 instead 3800 (mobo and processor do for save energy). So i was monitoring and finally runing superpi and outerra at 3800 mh (i have i7 3770k). Superpi result now is ok (9.7 s).
With outerra runing at 3800 all is better, but still slowdown. The first moment i run all seems work better. But while im flying the terrain is like overcharge, then begin problems.
Also for example, if i want load without problem the terrain detail, in everest i need t put at 320, in Swiss at 600, and in my place at 720.
If i put more resolution, when i go near terrain i dont see the maximun resolution. Resolution get stuck.  As i said maybe at the very begining no, but after some minute playing yes.

Also some glitches, mountains cut at some distance, then when you go near appear completely. This is in some points only (always same points).
So maybe now is more a bug version problem than my computer fault (while i am still testing things here coz my computer can be tricky.. ))

You think people those problems are common now in you too?

PD: It seems you added the very last version for download. thats great coz i am reinstaling engine several times lately and was quite desperate download 4 or 5 updates everytime. Now just click and install!! Nice. 
« Last Edit: January 21, 2017, 09:15:56 am by josem75 »
Logged

TobiWahn_Kenobi

  • Jr. Member
  • *
  • Posts: 10
Re: Graphics driver issues, startup problems
« Reply #707 on: June 02, 2017, 07:27:57 am »

Thanks. My problem might stem from the fact that I also have a hd5870 in my setup (macpro, old card needed for boot screen)


Sent from my iPad using Tapatalk

Hi again. Bought a GeForce GT120 instead of the HD5870, reinstalled the drivers for the RX480 (after using DDU). OGL now reads: OpenGLĀ® Version 6.14.10.13474

Still crashes on Startup telling me Catalyst was installed incorrectly. Eng attached:
Logged

byte512

  • Newbie
  • Posts: 7
Re: Graphics driver issues, startup problems
« Reply #708 on: June 10, 2017, 09:08:55 am »

In the latest version (17.0.2.8079) i have encountered a pretty serious graphical bug when trying to look at the building scenery for Bern
(Also: Noise Warning for the video):



The Video was filmed with ShadowPlay.
Does anyone have any idea how to fix this?

System:
OS: Windows 10 version 1703 64bit
CPU: Intel Corei7 2600K
Graphics Card: Gigabyte Geforce GTX 780
Graphics Card BIOS version: 80.10.37.00.23
Graphics Driver: 22.21.13.8253 (ForceWare 382.53) WHQL / Win10 64

Attached are the configuration- and logfiles from a run i did today.
The eng.log file can be downloaded here (it is to big to attach here):
https://www.dropbox.com/s/z3bgixlvufijacc/eng2.log?dl=0
Also: who thought replacing every instance of eng.log with a link was a good idea??
« Last Edit: June 10, 2017, 09:25:36 am by byte512 »
Logged

2eyed

  • Sr. Member
  • ****
  • Posts: 350
  • newbie
Re: Graphics driver issues, startup problems
« Reply #709 on: June 10, 2017, 09:26:25 am »

Similar results for me when approaching Bern/Swizerland in VR (as I'm always in VR in OT). Can lead to a crash.
But I thought it would be an issue specific to VR only.
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #710 on: June 10, 2017, 09:54:43 am »

Could you please do the following:
- press alt+c, a console should appear
- type:
  .bind f fb
  f.set_max_bloom_level(2)
- press esc key to close the console

Black squares should be reduced to small ones by this, and it should be easier to find what object or feature is causing it.
Logged

byte512

  • Newbie
  • Posts: 7
Re: Graphics driver issues, startup problems
« Reply #711 on: June 10, 2017, 05:08:43 pm »

Thanks for the fast answer cameni!

After doing what you asked me to, the result is the following:



It seems to be caused by a variety of objects from the converted w2xp buildings.
As seen a few times in the video, the sky also turns kind of dark for some viewing angles.
In addition to what is visible in the video, some buildings that turn black vanish from some viewing angles, while others that turn black don't seem to.
For some hard to find viewing angles, the clouds start creating weird artifacts as well (this only happens with the Bern scenery).
Last but not least i have once seen an artifact in combination with this, where contents of the previous few frames are visible at the place where a building should be.

The engine log was again to big to upload as an attachment, so it can be downloaded via the following link:
https://www.dropbox.com/s/mvpweng9461owtr/eng3.log?dl=0

EDIT: It might be worth noting, that i had the same problem in either version 17.0.1.7885 or version 16.1.0.7503 with the cessna and maybe other vehicles causing these artifacts, but not the buildings.
I only looked at the Bern area at that time though, so the problem might have been caused by the scenery.
In version 17.0.2.8079 i don't have that problem with any of the vehicles.
« Last Edit: June 10, 2017, 05:25:01 pm by byte512 »
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #712 on: June 11, 2017, 02:14:16 am »

Hm, at some point it looks like you were under fog. In any case it seems to be a material error, and I suspect MSAA = 8 has something to do with it as well.

Quote
Also: who thought replacing every instance of eng.log with a link was a good idea??

I grew tired having to explain million times where the eng.log was. I could not make the forums to display just a popup message on hover, so I had to do it this way.
Logged

Uriah

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 569
  • We do these things not because they are easy. -JFK
Re: Graphics driver issues, startup problems
« Reply #713 on: June 11, 2017, 08:48:24 am »

In eng.cfg you can set:

pkg_limits =  (pkg_limits) {
   max_meshes = 4
},

Because there are so many objects in that scenery, setting to a higher value always fixes these issues for me.
Logged

andfly

  • Sr. Member
  • ****
  • Posts: 293
Re: Graphics driver issues, startup problems
« Reply #714 on: June 11, 2017, 01:11:15 pm »

In the latest version (17.0.2.8079) i have encountered a pretty serious graphical bug when trying to look at the building scenery for Bern

I noticed that in your eng.cfg you have this setting:
 
min_obj_size = 0.1

I also had a similar problem the first time I visited Bern ... I resolved following the advice of Acetone:


Congrats for this release, it takes some special dedication to release an update the 31 December :)

It's so nice to finally see OSM in action!


Edit: As noted by HiFlyer, you could experience some rendering artifacts over the buildings depending on your hardware configuration. Be sure Minimum Object Size is set to 5.0 or higher in the graphics/setting menu, and change the variable so flickering/dark buildings are correctly rendered.
Logged
I do not know the English language. I use Google Translate. I hope it's all understandable.

byte512

  • Newbie
  • Posts: 7
Re: Graphics driver issues, startup problems
« Reply #715 on: June 11, 2017, 01:25:11 pm »

Thank you so much!! Both of these tips worked perfectly. Can anyone explain, what these settings do exactly?

In eng.cfg you can set:

pkg_limits =  (pkg_limits) {
   max_meshes = 4
},

Because there are so many objects in that scenery, setting to a higher value always fixes these issues for me.

I noticed that in your eng.cfg you have this setting:
 
min_obj_size = 0.1

I also had a similar problem the first time I visited Bern ... I resolved following the advice of Acetone:


Congrats for this release, it takes some special dedication to release an update the 31 December :)

It's so nice to finally see OSM in action!


Edit: As noted by HiFlyer, you could experience some rendering artifacts over the buildings depending on your hardware configuration. Be sure Minimum Object Size is set to 5.0 or higher in the graphics/setting menu, and change the variable so flickering/dark buildings are correctly rendered.

I tried to turn of antialiasing after reading your post cameni, and it made the issue much worse. Then again, any one of the cfg changes i quoted above work like a charm.
Hm, at some point it looks like you were under fog. In any case it seems to be a material error, and I suspect MSAA = 8 has something to do with it as well.
« Last Edit: June 11, 2017, 02:16:10 pm by byte512 »
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #716 on: June 11, 2017, 03:25:34 pm »

I tried to turn of antialiasing after reading your post cameni, and it made the issue much worse. Then again, any one of the cfg changes i quoted above work like a charm.

Interesting. The min object size setting says what minimal mesh size on screen is allowed; meshes smaller than given pixel size are not rendered. I guess what happens there is that very small meshes get their triangle vertices transformed to the same screen space positions (equal with regards to the internal GPU interpolation precision), and a subsequent computation results in a div by zero. I assumed that with MSAA this will happen sooner because of additional subsamples ...
Logged

byte512

  • Newbie
  • Posts: 7
Re: Graphics driver issues, startup problems
« Reply #717 on: June 11, 2017, 06:01:07 pm »

Well when i said that it got worse, what i meant was that the black artifacts were now a lot bigger than with MSAA, nearly blacking out my screen entirely.
I tried to turn of antialiasing after reading your post cameni, and it made the issue much worse. Then again, any one of the cfg changes i quoted above work like a charm.

Interesting. The min object size setting says what minimal mesh size on screen is allowed; meshes smaller than given pixel size are not rendered. I guess what happens there is that very small meshes get their triangle vertices transformed to the same screen space positions (equal with regards to the internal GPU interpolation precision), and a subsequent computation results in a div by zero. I assumed that with MSAA this will happen sooner because of additional subsamples ...
Logged

marcel250

  • Jr. Member
  • *
  • Posts: 17
Re: Graphics driver issues, startup problems
« Reply #718 on: July 04, 2017, 12:41:48 pm »

When I open OT and I do another thing, like watching a video, Outerra crashes.

Then, when I open Outerra again, it runs but painfully slow.

What can I do to solve this problem?
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6714
  • No sense of urgency.
    • outerra.com
Re: Graphics driver issues, startup problems
« Reply #719 on: July 05, 2017, 04:35:28 am »

Sounds like a hardware problem, or too little GPU memory shared among multiple applications.
Logged
Pages: 1 ... 46 47 [48] 49 50 51