Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Pages: [1] 2

Author Topic: Linux support?  (Read 19987 times)

Legendman3

  • Newbie
  • Posts: 4
  • newbie
Linux support?
« on: March 03, 2012, 02:28:04 pm »

Is there/Will there be linux support? If not then ill have to stick to WINE.
Logged

[deleted]

  • Full Member
  • ***
  • Posts: 232
Re: Linux support?
« Reply #1 on: March 03, 2012, 02:37:52 pm »

Yes, cameni confirmed it.
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6721
  • No sense of urgency.
    • outerra.com
Re: Linux support?
« Reply #2 on: March 03, 2012, 02:41:08 pm »

Planned, but not sure about when, focusing on usability on Win first.
Did anyone try it under WINE?
Logged

Legendman3

  • Newbie
  • Posts: 4
  • newbie
Re: Linux support?
« Reply #3 on: March 03, 2012, 03:24:22 pm »

Let me try it really quick.
Logged

Legendman3

  • Newbie
  • Posts: 4
  • newbie
Re: Linux support?
« Reply #4 on: March 03, 2012, 03:33:55 pm »

Ok so when i run it under wine i get the warning saying untested graphics card (Because i have a intel integrated chipset, btw are nvidia/ATI graphic cards required to run outerra?) and then it shows up with a transparent screen.

Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6721
  • No sense of urgency.
    • outerra.com
Re: Linux support?
« Reply #5 on: March 03, 2012, 05:22:25 pm »

Intel graphics chips, in addition to their poor performance, don't support OpenGL 3.3. It won't run on it ...
Logged

Legendman3

  • Newbie
  • Posts: 4
  • newbie
Re: Linux support?
« Reply #6 on: March 04, 2012, 07:04:30 pm »

Dammit.
Logged

giucam

  • Full Member
  • ***
  • Posts: 171
  • It's an ugly pile of bones... like me.
Re: Linux support?
« Reply #7 on: July 01, 2012, 10:33:31 am »

I have the same problem as Legendman3. I have an ATI HD4850, and i know for sure Outerra runs with it, since it runs in my win7 installation, but still in my Archlinux i get the warning and the transparent screen.

That's the output i get, before it hangs, even though i doubt it's useful. Is there some console switch to make outerra more verbose?
Code: [Select]
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:win:EnumDisplayDevicesW ((null),0,0x33f798,0x00000000), stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33fbd8
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x33fb6c, uiNumDevices=1, cbSize=12) stub!
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x33fb78, uiNumDevices=1, cbSize=12) stub!
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x33fb84, uiNumDevices=1, cbSize=12) stub!
^C^Cerr:seh:raise_exception Unhandled exception code c000013a flags 0 addr 0xb77f8424
err:ntdll:RtlpWaitForCriticalSection section 0x7ba3c7a0 "../../../wine/dlls/kernel32/console.c: CONSOLE_CritSect" wait timed out in thread 0036, blocked by 0033, retrying (60 sec)

I'm using the catalyst 12.4, and it supports gl 3.3:
Code: [Select]
OpenGL version string: 3.3.11631 Compatibility Profile Context
OpenGL shading language version string: 3.30
Moreover, i can get Proland to run, which i guess has similar requirements, even if with some changes to the code and some rendering artifacts. (Too bad Outerra isn't open source too ;))

p.s. Great great work with this, anyway! I guess i'll buy it asap. :)
Logged
ResidualVM 0.1.1 is OUT! www.residualvm.org

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6721
  • No sense of urgency.
    • outerra.com
Re: Linux support?
« Reply #8 on: July 01, 2012, 12:38:56 pm »

Those fixme messages are not from Outerra, but I guess it's the WINE reporting that some of the functions or their arguments not being implemented yet (stubs).
Seems the show stopper is the use of raw input functions here ...
Logged

giucam

  • Full Member
  • ***
  • Posts: 171
  • It's an ugly pile of bones... like me.
Re: Linux support?
« Reply #9 on: July 01, 2012, 01:20:46 pm »

Yes. Indeed i had the feeling i already read those messages, so i tried to run some .exe and i found out that with e.g. kerbal space program too wine prints those RegisterRawInputDevices warnings. But it doesn't stop ksp to run, so i don't think that's the problem.

I tried to run it in winedbg, and i got a backtrace by 'Ctrl-C'ing after it hanged . Maybe you can understand what's the matter even without the debug symbols.
Code: [Select]
Wine-dbg>bt
Backtrace:
=>0 0xb7795424 __kernel_vsyscall+0x10() in [vdso].so (0x0033fbfc)
  1 0xb7522411 in libc.so.6 (+0xe1410) (0x0033fbfc)
  2 0x7bc7c0ef NtDelayExecution+0xde() in ntdll (0x0033fbfc)
  3 0x7b86dda2 SleepEx+0x31() in kernel32 (0x0033fc2c)
  4 0x7b86ddf7 Sleep+0x26() in kernel32 (0x0033fc4c)
  5 0x0062bcef in outerra (+0x22bcee) (0x0033fd28)
  6 0x0056bd07 in outerra (+0x16bd06) (0x0033fd84)
Wine-dbg>

cheers
Logged
ResidualVM 0.1.1 is OUT! www.residualvm.org

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6721
  • No sense of urgency.
    • outerra.com
Re: Linux support?
« Reply #10 on: July 01, 2012, 02:55:05 pm »

That's just a thread that's in sleep, some other thread is looping somewhere. I would need to look at it myself. Btw is there an eng.log file created?
Logged

giucam

  • Full Member
  • ***
  • Posts: 171
  • It's an ugly pile of bones... like me.
Re: Linux support?
« Reply #11 on: July 01, 2012, 03:51:41 pm »

Btw is there an eng.log file created?
Yep:
Code: [Select]
INFO: Outerra 0.7.11, build 3100 from Sun, 10 Jun 2012 12:42:18 GMT
INFO: Initializing engine...
INFO: data root directory: Z:\media\Volume\Outerra\Anteworld\
INFO: Windows version: 6.1.7601
INFO: CPU info:
        CPU string: GenuineIntel
        CPU brand string: Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz
        Stepping ID: 2
        Model: 15
        Family: 6
        Processor type: 0
        Extended model: 0
        Extended family: 0
        Brand Index: 0
        CLFLUSH cache line size: 64
        APIC Physical ID: 1

INFO: GPU System info
    Graphics card: X11 Windowing System
    GPU vendor ID: 0000 (Unknown)
    GPU device ID: 0000
    OpenGL driver version:  ()
    OpenGL driver build number: 0


INFO: Reading Z:\media\Volume\Outerra\Anteworld\eng.cfg
INFO:   init timer to 1ms
INFO: Outerra window created size 1286x745
INFO: Starting JobMaster...
INFO: Creating JobMaster thread 0
INFO: Creating JobMaster thread 1
INFO: Creating JobMaster thread 2
INFO: Creating JobMaster thread 3
INFO: Creating JobMaster thread 4
INFO: Creating JobMaster thread 5
INFO: Creating JobMaster thread 6
INFO: Creating JobMaster thread 7
INFO: Event "reverse" already defined, overriding with latest definition.
INFO: Event "reverse" already defined, overriding with latest definition.
INFO: Event "steer_left" already defined, overriding with latest definition.
INFO: Event "steer_left" already defined, overriding with latest definition.
INFO: Event "accelerate" already defined, overriding with latest definition.
INFO: Event "accelerate" already defined, overriding with latest definition.
INFO: Event "steer_right" already defined, overriding with latest definition.
INFO: Event "steer_right" already defined, overriding with latest definition.
INFO: Event "elevator_up" already defined, overriding with latest definition.
INFO: Event "rudder_right" already defined, overriding with latest definition.
INFO: Event "flaps_down" already defined, overriding with latest definition.
INFO: Event "flaps_up" already defined, overriding with latest definition.
INFO: Event "elevator_down" already defined, overriding with latest definition.
INFO: Event "pause_simulation" already defined, overriding with latest definition.
INFO: Event "brake" already defined, overriding with latest definition.
INFO: Event "rudder_left" already defined, overriding with latest definition.
INFO: Event "aileron_right" already defined, overriding with latest definition.
INFO: Event "start_stop_engine" already defined, overriding with latest definition.
INFO: Event "aileron_left" already defined, overriding with latest definition.
INFO: Event "trim" already defined, overriding with latest definition.
INFO: Event "cyclic_longitudal_back" already defined, overriding with latest definition.
INFO: Event "toggle_hover_mode" already defined, overriding with latest definition.
INFO: Event "cyclic_lateral_right" already defined, overriding with latest definition.
INFO: Event "anti_torque_right" already defined, overriding with latest definition.
INFO: Event "cyclic_longitudal_forward" already defined, overriding with latest definition.
INFO: Event "cyclic_lateral_left" already defined, overriding with latest definition.
INFO: Event "anti_torque_left" already defined, overriding with latest definition.
DEBUG: (io_man) event group "player" has been activated...
INFO: Available display modes:
    1280x1024@60 default
    1280x1024@75 default
    1280x800@60 default
    1280x800@75 default
    1280x720@60 default
    1280x960@75 default
    1280x960@60 default
    1152x864@75 default
    1152x864@60 default
    1280x768@75 default
    1280x768@60 default
    1024x768@75 default
    1024x768@70 default
    1024x768@60 default
    800x600@72 default
    800x600@75 default
    800x600@70 default
    800x600@60 default
    720x480@60 default
    640x480@75 default
    640x480@73 default
    640x480@60 default

INFO:
Available Capture Devices are:-
ALSA Default
HDA Intel, ALC888 Analog (CARD=Intel,DEV=0)
HDA Intel, ALC888 Analog (CARD=Intel,DEV=2)

INFO: Sound system information
    Using OpenAL device (OpenAL Soft)
    Using OpenAL capture device (OpenAL Soft)
    ALC_FREQUENCY: 44100
    ALC_REFRESH: 43
    ALC_SYNC: 0
    ALC_MONO_SOURCES: 255
    ALC_STEREO_SOURCES: 1


INFO: Could not retrieve loaded modules, error: -1073741823
INFO: SetFileCompletionNotificationModes not present
INFO: renderer: thread started...
INFO: Searching suitable pixel format...
DEBUG: job "sndfile_load_task" processed in 56ms
DEBUG: job "sndfile_load_task" processed in 72ms
INFO: Pixel format has been found: 10
INFO: Setting pixel format

Anyway I did a "bt all" in winedbg and this is what i got.
Logged
ResidualVM 0.1.1 is OUT! www.residualvm.org

PRiME

  • Full Member
  • ***
  • Posts: 170
  • newbie
Re: Linux support?
« Reply #12 on: August 06, 2015, 07:03:55 am »

Sorry to dig this up, I'm wondering if anyone got this working under Wine.

I run Linux Mint 17.1 XFCE with latest Nvidia drivers (980GTX) and get these errors before application fails and closes down.

1) Unable to find Nvidia driver version number. Please update you graphics card drivers,......
2) Error initializing OpenGL subsystem. This program requires OpenGL 3.3 capable graphics card with recent drivers. No suitable pixel format found.

Seems like it needs OpenGL 3.3 files whereas I believe I run 4.3 or something, anyone who knows how one might fix this let me know. Cheers.

« Last Edit: August 06, 2015, 07:44:35 am by PRiME »
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6721
  • No sense of urgency.
    • outerra.com
Re: Linux support?
« Reply #13 on: August 06, 2015, 07:13:58 am »

It will use a newer OpenGL version too, 3.3 is just the minimum it requires. The error means it wasn't able to find the drivers.
Logged

PRiME

  • Full Member
  • ***
  • Posts: 170
  • newbie
Re: Linux support?
« Reply #14 on: August 06, 2015, 07:43:39 am »

Yes it seems reinstalling the Nvidia drivers solved those errors and it appears to be working now. Lets hope it renders everything correctly. Thank you for the quick reply.

I believe some program overwritten my 32 bit nvidia driver libs at some point.


EDIT: Yep works great, now I can continue making faulty tanks for my tank game project :-)    (It also runs good at 4k under Linux :o)
« Last Edit: August 06, 2015, 07:57:21 am by PRiME »
Logged
Pages: [1] 2