Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Author Topic: Crash upon start  (Read 4282 times)

JW1904

  • Newbie
  • Posts: 5
  • newbie
Crash upon start
« on: March 13, 2012, 09:34:21 am »

Hello!

I've downloaded and installed the game. First time running, it warned me that I had to update my graphiccard drivers, to prevent problems ingame. Well, alright, most games still work with older driver-versions. Yet, the game instantly crashed.

I than updated the graphiccard driver, and tried restarting the game. It still crashes.

Windows 7 Ultimate x64
Intel E8500
Nvidia Geforce 9800GTx+
4Gb's of ram
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6670
  • Pegs is clever, but tae hain’t a touch sentimental
    • outerra.com
Re: Crash upon start
« Reply #1 on: March 13, 2012, 09:44:07 am »

Did it send a crash report or was it a driver crash that didn't bring up the crash reporter?

It needs the newest drivers because it uses recent OpenGL functionality that was buggy in older drivers. Most games/engines use older hw features and driver code paths that are verified by the time, but don't fully utilize the hw capabilities.
Logged

JW1904

  • Newbie
  • Posts: 5
  • newbie
Re: Crash upon start
« Reply #2 on: March 13, 2012, 09:45:48 am »

Thats a fast reaction, thanks. No, it was a game-crash. And, I doubt that it send a crash-report, as I canceled when it prompted me to use Outlook to send it. The driver was doing fine and didn't crash.
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6670
  • Pegs is clever, but tae hain’t a touch sentimental
    • outerra.com
Re: Crash upon start
« Reply #3 on: March 13, 2012, 09:54:05 am »

If it brings up our crash sender (with red text asking for the description), please let it send the report so we can analyze it.

Also, some sw is known to interfere with it: Bitdefender, MSI afterburner and several more. These usually result in a black screen, but it's possible there are ones that crash it.
Logged

JW1904

  • Newbie
  • Posts: 5
  • newbie
Re: Crash upon start
« Reply #4 on: March 13, 2012, 10:04:15 am »

Can't. It tell's me that it will start MS Outlook to send the report. I don't use it, its just installed there.

I zipped the files and uploaded them instead: http://www.mediafire.com/?fs7aagwha9mxf9a
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6670
  • Pegs is clever, but tae hain’t a touch sentimental
    • outerra.com
Re: Crash upon start
« Reply #5 on: March 13, 2012, 10:23:52 am »

The crash sender first tries to connect to our server to send the report directly via http, so it looks like it cannot connect. And also according to the crash report, there's a problem with networking (though the crash our bug). The program connects to our servers to check if new updates or fixed data are available, so without the net it won't work properly.
Logged

JW1904

  • Newbie
  • Posts: 5
  • newbie
Re: Crash upon start
« Reply #6 on: March 13, 2012, 11:36:25 am »

Alright, I'm using Comodo, and configured the game as safe-application. Yet, it still crashes. Now it does however prompt me with 2 messages. One having a status-bar filling up, and disapearing within a few seconds. The other one to send it manually, but that won't work as it still wants to use Outlook.
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6670
  • Pegs is clever, but tae hain’t a touch sentimental
    • outerra.com
Re: Crash upon start
« Reply #7 on: March 13, 2012, 11:51:03 am »

Well, security.

It downloads an update, tries to install it but something in your defenses is probably shooting it down :)
You can download and install the patch manually Anteworld-0.7.11.2968.patch-3004.exe

But I guess further problems can be expected ...
Logged

JW1904

  • Newbie
  • Posts: 5
  • newbie
Re: Crash upon start
« Reply #8 on: March 13, 2012, 11:52:14 am »

Lets try it. Disabled Comodo, tried again, and it still failed. Lets see what it does after installing the patch myself.

€dit: Terminated Comodo "I'll be back!". Now it seems to work. Thanks!
« Last Edit: March 13, 2012, 11:53:56 am by JW1904 »
Logged