Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Pages: [1] 2 3

Author Topic: Odd shadow-like thing on imported models  (Read 14972 times)

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Odd shadow-like thing on imported models
« on: January 02, 2013, 05:11:07 pm »

Trying to import just a few assets to test and we keep getting this dark shadow look:



Using DXT1 format, made several changes, all with same result.

If I import it into UDK it had no issues.

Any ideas?
Logged

Midviki

  • Full Member
  • ***
  • Posts: 242
  • Nothing matters... but everything is important.
Re: Odd shadow-like thing on imported models
« Reply #1 on: January 03, 2013, 01:19:41 am »

Well... you need to give more details.For starters... what software are you using? Cause I had a problem.. and it was a full black texture on the object.But the cause of the problem was directory path problem.But now it works fine, and I'm using 3ds Max + Photoshop.

And the DXT1 format option... try to use the "default".There are other options that work as well with Outerra.. but my "default" is :

Logged
ATI AMD RADEON HD 6670

Midviki

  • Full Member
  • ***
  • Posts: 242
  • Nothing matters... but everything is important.
Re: Odd shadow-like thing on imported models
« Reply #2 on: January 03, 2013, 01:32:35 am »

Ah.. yeah.. and the Collada export options ( make sure you export it directly to a short path( long links may not read the texture ), and yeah dont copy the export... it doesent work sometimes or most of the times (use the original export) ):


Logged
ATI AMD RADEON HD 6670

angrypig

  • Sr. Member
  • ****
  • Posts: 454
Re: Odd shadow-like thing on imported models
« Reply #3 on: January 04, 2013, 06:11:44 am »

Can you send us exported COLLADA file?
Logged

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Re: Odd shadow-like thing on imported models
« Reply #4 on: January 04, 2013, 08:27:57 am »

Sure no problem.

See attached.
Logged

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Re: Odd shadow-like thing on imported models
« Reply #5 on: January 05, 2013, 11:17:00 am »

Can you send us exported COLLADA file?

Any news on this yet Angrypig?

I have even attached a new file (dae) with the model saved as Triangles.
« Last Edit: January 05, 2013, 11:23:56 am by maxdmg »
Logged

angrypig

  • Sr. Member
  • ****
  • Posts: 454
Re: Odd shadow-like thing on imported models
« Reply #6 on: January 05, 2013, 11:52:29 am »

It seems like an older bug in the engine, try to add another object into scene like cessna or tatra... i'm trying to find this bug but it's not easy...
Logged

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Re: Odd shadow-like thing on imported models
« Reply #7 on: January 05, 2013, 03:31:13 pm »

I tried to import just a wall and had some odd results. See below.
                              In the engine                                                                              Not in the engine



Is this related to the same Bug?

BTW using the build from yesterday, still getting same results.
Thanks
Logged

angrypig

  • Sr. Member
  • ****
  • Posts: 454
Re: Odd shadow-like thing on imported models
« Reply #8 on: January 05, 2013, 04:07:24 pm »

You can't compare texture with screenshot from the engine. In the engine the sun light and sky ambient light is applied. There is another set of parameters from material definition like color multiplier, roughness, reflectance that can completely change the final color.

And it seems the wall is in the shadow that is why it has blueish tint.
Logged

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Re: Odd shadow-like thing on imported models
« Reply #9 on: January 05, 2013, 04:25:44 pm »

I agree, It looks like a shadow..but where in the middle of no where at the airport you guys have in the engine is it getting it?

See below:

« Last Edit: January 05, 2013, 04:38:29 pm by maxdmg »
Logged

angrypig

  • Sr. Member
  • ****
  • Posts: 454
Re: Odd shadow-like thing on imported models
« Reply #10 on: January 05, 2013, 04:46:32 pm »

please send me the imported package, there is something wrong there...
Logged

Midviki

  • Full Member
  • ***
  • Posts: 242
  • Nothing matters... but everything is important.
Re: Odd shadow-like thing on imported models
« Reply #11 on: January 05, 2013, 04:47:51 pm »

I think he needs more polys.I think I had that problem with huge objects with few polys.
Logged
ATI AMD RADEON HD 6670

angrypig

  • Sr. Member
  • ****
  • Posts: 454
Re: Odd shadow-like thing on imported models
« Reply #12 on: January 05, 2013, 04:50:08 pm »

hmm yes if such big object has 6 triangles it can be problem
Logged

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Re: Odd shadow-like thing on imported models
« Reply #13 on: January 05, 2013, 05:07:34 pm »

Great idea looking in to this now.  Details to follow.
Logged

maxdmg

  • Jr. Member
  • *
  • Posts: 23
Re: Odd shadow-like thing on imported models
« Reply #14 on: January 05, 2013, 10:54:03 pm »

hmm yes if such big object has 6 triangles it can be problem

Ok have now shrunk the assets, and increased the Tri count, here are the results:


Be Damned if I know where the shadow is coming from... Prob Aliens!!
Logged
Pages: [1] 2 3