Outerra forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Outerra Tech Demo download. Help with graphics driver issues

Author Topic: Fatal error immediately on startup  (Read 203 times)

er202506

  • Newbie
  • Posts: 2
Fatal error immediately on startup
« on: December 30, 2018, 09:12:17 pm »

I'm not quite sure what i did, but i now get the following error message right after i click the game icon to start it:
"Error reading eng.cfg:
C:/Users/Species8472/Outerra/eng.cfg:8 :
:engine_config.renderer_config:renderer_config - member
variable: debug_opengl not defined
debug_opengl = false,
^"
What exactly does this mean?
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6542
  • Pegs is clever, but tae hain’t a touch sentimental
    • outerra.com
Re: Fatal error immediately on startup
« Reply #1 on: December 31, 2018, 05:07:54 am »

Config files are backward compatible, but not forward - that means you seem to be using a newer config file with an older outerra.exe version.
This usually happens when there was an update, and an overeager (read "stupid") antivirus or some such scareware reverts the executable ...

Just delete the cfg files, they will be regenerated. Actually they should be deleted automatically after the error, so the problem may be elsewhere.
« Last Edit: December 31, 2018, 05:10:37 am by cameni »
Logged

er202506

  • Newbie
  • Posts: 2
Re: Fatal error immediately on startup
« Reply #2 on: December 31, 2018, 09:04:59 am »

I'm downloading the latest version now. Should i still only delete the files that include "cfg" in their title?
Logged

cameni

  • Brano Kemen
  • Outerra Administrator
  • Hero Member
  • *****
  • Posts: 6542
  • Pegs is clever, but tae hain’t a touch sentimental
    • outerra.com
Re: Fatal error immediately on startup
« Reply #3 on: December 31, 2018, 11:23:00 am »

Latest version should handle them as they are. Only the old version can't open them. In any case it's safe to delete the cfg files in the data dir in case of problems, they will be regenerated.
Logged